Skip to main content
Support - EBSCO Help

Flipster - Desktop and Mobile Requirements

Desktop Requirements

Flipster has been tested and confirmed to work on your desktop computer with the following browsers:

Internet Explorer Internet Explorer 10 and 11 only
FireFox Latest and one previous version
Safari Latest and one previous version
Google Chrome Latest and one previous version
Other JavaScript, Cookies Enabled

Notes:

  • Adobe Flash Player 10.0 or later is required to use Text-To-Speech on interfaces in which it is available.

  • If you are using an older browser, Flipster may function properly, but your results may vary.

  • The recommended screen resolution is 1024 x 768.

Mobile Requirements

While the Flipster interface and mobile viewer should be accessible using most mobile operating systems, the following operating systems have been tested and confirmed to be supported by Flipster:

  • iOS - Versions 9 and higher
  • Android - Version 4.2.2 (Jelly Bean) and higher

If you are using a different mobile operating system, your Flipster experience may vary.