Skip to main content
Support - EBSCO Help

Browser and Operating System Requirements for EBSCO eBooks

The minimum Browser and Operating System requirements for reading EBSCO eBooks online are as follows:

Internet Explorer 11.0 or later
FireFox Latest version plus one previous version
Safari 11.0 or later
Google Chrome Latest version plus one previous version
iOS 11.0 or later
Other JavaScript, Cookies Enabled, DOM Storage

 

For Adobe Acrobat Reader Browser Requirements and settings for all supported browsers, click here.

 

See also: